Degraded experience when creating or editing campaigns
Incident Report for NextRoll
Resolved
This incident has been resolved.
Posted Dec 27, 2023 - 12:24 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 27, 2023 - 09:38 PST
Investigating
We are currently investigating this issue.
Posted Dec 27, 2023 - 08:10 PST
This incident affected: AdRoll (AdRoll Ad Campaign) and RollWorks (RollWorks Campaigns).