Workflow reports are currently unavailable for downloading.

Incident Report for NextRoll

Resolved

This incident has been resolved.
Posted Apr 02, 2026 - 19:39 PDT

Update

We are continuing to work on a fix for this issue.
Posted Apr 02, 2026 - 19:03 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 02, 2026 - 19:02 PDT
This incident affected: AdRoll ABM (AdRoll ABM Workflows).