Dashboard is not loading on certain tabs
Incident Report for NextRoll
Resolved
This incident has been resolved.
Posted May 19, 2022 - 09:41 PDT
Investigating
We are currently investigating this issue.
Posted May 19, 2022 - 09:08 PDT
This incident affected: RollWorks (RollWorks Impact Overview Dashboard, RollWorks Campaigns) and AdRoll (AdRoll Dashboard, AdRoll Ad Campaign).