Negatively targeted geotargets are not being correctly saved.
Incident Report for NextRoll
Resolved
We have released the fix this morning and this issue has been resolved.
Posted Dec 13, 2021 - 06:50 PST
Investigating
Negatively targeted geotargets are not being correctly saved. Engineering is looking into the issue.
Posted Dec 09, 2021 - 18:08 PST
This incident affected: AdRoll (AdRoll Ad Campaign).