[AdRoll Only] Cross-Channel Dashboard is currently unavailable
Incident Report for NextRoll
Resolved
This incident has been resolved.
Posted May 19, 2022 - 15:56 PDT
Investigating
We are currently investigating this issue.
Posted May 19, 2022 - 15:42 PDT
This incident affected: AdRoll (AdRoll Dashboard).