The Engineering team is investigating reports of campaign tabs not loading in the dashboard for subset of customers.

Incident Report for NextRoll

Resolved

This incident has been resolved.
Posted Sep 04, 2025 - 15:41 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 04, 2025 - 15:22 PDT

Investigating

We are currently investigating this issue.
Posted Sep 04, 2025 - 13:01 PDT
This incident affected: AdRoll (AdRoll Dashboard, AdRoll Ad Campaign).