Ads API hard deleting data denoting relationships between AdGroups and Ads
Incident Report for NextRoll
Resolved
The recovery of data denoting the relationship between AdGroups and their Ads is completed.
Posted Jan 16, 2024 - 07:14 PST
Update
A fix for the issue has been deployed to production. In addition, a recovery procedure has also been defined, and we estimate to have a majority of the data denoting the relationship between AdGroups and their Ads restored around Tuesday/Wednesday next week.
Posted Jan 10, 2024 - 07:39 PST
Identified
Issue:
Our Ad APIs are having issues where data denoting the relationship between AdGroups and their Ads are being hard deleted from Web Retargeting campaigns' AdGroups instead of soft-deleting them.

Impact:
Affects Web Retargeting campaign details and reports page where deleted Ads under their parent AdGroups are no longer shown.
Scheduled reports are also missing deleted Ad metrics.
Next Steps:
A fix for this will be deployed in the next couple of hours. Engineering is currently evaluating possible strategies to recover Ad data that has been hard-deleted.
Posted Jan 09, 2024 - 12:17 PST
This incident affected: API.